Jump to content

CraftersLand Launcher Released! [v1.1.7 Fine-Tune your experience to the max!


Recommended Posts

Error popped up pls help me  (using cracked)

com.fasterxml.jackson.databind.JsonMappingException: Can not construct instance of com.skcraft.launcher.model.minecraft.Library$Action, problem: No enum constant com.skcraft.launcher.model.minecraft.Library.Action.DİSALLOW
 at [Source: java.io.StringReader@1df4210c; line: 1, column: 208756] (through reference chain: com.skcraft.launcher.model.modpack.Manifest["versionManifest"]->com.skcraft.launcher.model.minecraft.VersionManifest["libraries"]->com.skcraft.launcher.model.minecraft.Library["rules"]->com.skcraft.launcher.model.minecraft.Rule["action"])
    at com.fasterxml.jackson.databind.JsonMappingException.from(JsonMappingException.java:170)
    at com.fasterxml.jackson.databind.DeserializationContext.instantiationException(DeserializationContext.java:710)
    at com.fasterxml.jackson.databind.deser.std.EnumDeserializer$FactoryBasedDeserializer.deserialize(EnumDeserializer.java:168)
    at com.fasterxml.jackson.databind.deser.SettableBeanProperty.deserialize(SettableBeanProperty.java:525)
    at com.fasterxml.jackson.databind.deser.impl.MethodProperty.deserializeAndSet(MethodProperty.java:99)
    at com.fasterxml.jackson.databind.deser.BeanDeserializer.vanillaDeserialize(BeanDeserializer.java:242)
    at com.fasterxml.jackson.databind.deser.BeanDeserializer.deserialize(BeanDeserializer.java:118)
    at com.fasterxml.jackson.databind.deser.std.CollectionDeserializer.deserialize(CollectionDeserializer.java:227)
    at com.fasterxml.jackson.databind.deser.std.CollectionDeserializer.deserialize(CollectionDeserializer.java:204)
    at com.fasterxml.jackson.databind.deser.std.CollectionDeserializer.deserialize(CollectionDeserializer.java:23)
    at com.fasterxml.jackson.databind.deser.SettableBeanProperty.deserialize(SettableBeanProperty.java:525)
    at com.fasterxml.jackson.databind.deser.impl.MethodProperty.deserializeAndSet(MethodProperty.java:99)
    at com.fasterxml.jackson.databind.deser.BeanDeserializer.vanillaDeserialize(BeanDeserializer.java:242)
    at com.fasterxml.jackson.databind.deser.BeanDeserializer.deserialize(BeanDeserializer.java:118)
    at com.fasterxml.jackson.databind.deser.std.CollectionDeserializer.deserialize(CollectionDeserializer.java:227)
    at com.fasterxml.jackson.databind.deser.std.CollectionDeserializer.deserialize(CollectionDeserializer.java:204)
    at com.fasterxml.jackson.databind.deser.std.CollectionDeserializer.deserialize(CollectionDeserializer.java:23)
    at com.fasterxml.jackson.databind.deser.SettableBeanProperty.deserialize(SettableBeanProperty.java:525)
    at com.fasterxml.jackson.databind.deser.impl.MethodProperty.deserializeAndSet(MethodProperty.java:99)
    at com.fasterxml.jackson.databind.deser.BeanDeserializer.vanillaDeserialize(BeanDeserializer.java:242)
    at com.fasterxml.jackson.databind.deser.BeanDeserializer.deserialize(BeanDeserializer.java:118)
    at com.fasterxml.jackson.databind.deser.SettableBeanProperty.deserialize(SettableBeanProperty.java:525)
    at com.fasterxml.jackson.databind.deser.impl.MethodProperty.deserializeAndSet(MethodProperty.java:99)
    at com.fasterxml.jackson.databind.deser.BeanDeserializer.vanillaDeserialize(BeanDeserializer.java:242)
    at com.fasterxml.jackson.databind.deser.BeanDeserializer.deserialize(BeanDeserializer.java:118)
    at com.fasterxml.jackson.databind.ObjectMapper._readMapAndClose(ObjectMapper.java:2986)
    at com.fasterxml.jackson.databind.ObjectMapper.readValue(ObjectMapper.java:2091)
    at com.skcraft.launcher.util.HttpRequest$BufferedResponse.asJson(HttpRequest.java:461)
    at com.skcraft.launcher.update.BaseUpdater.installPackage(BaseUpdater.java:90)
    at com.skcraft.launcher.update.Updater.update(Updater.java:141)
    at com.skcraft.launcher.update.Updater.call(Updater.java:95)
    at com.skcraft.launcher.update.Updater.call(Updater.java:38)
    at java.util.concurrent.FutureTask.run(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.IllegalArgumentException: No enum constant com.skcraft.launcher.model.minecraft.Library.Action.DİSALLOW
    at java.lang.Enum.valueOf(Unknown Source)
    at com.skcraft.launcher.model.minecraft.Library$Action.valueOf(Library.java:182)
    at com.skcraft.launcher.model.minecraft.Library$Action.fromJson(Library.java:188)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.fasterxml.jackson.databind.deser.std.EnumDeserializer$FactoryBasedDeserializer.deserialize(EnumDeserializer.java:162)
    ... 33 more
 

Link to post
Share on other sites
  • Replies 72
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

CraftersLand Launcher v1.1.7! (Me, Henk and Brunyman were discussing ideas to be brought into CraftersLand back in May)   And so it began, I embarked on the task to get it done after

Beautiful highres craftersland logo right there, some genius must’ve made it.  

Hey from what i know this normally get the error from not having correct java  So try installing this Java  https://javadl.oracle.com/webapps/download/AutoDL?BundleId=235696_2787e4a523244c269598d

Posted Images

  • 2 months later...

I keep on getting this problem, what do I do?

 

The game is running. Please wait.
Exception in thread "main" java.lang.UnsupportedClassVersionError: joptsimple/OptionSpec : Unsupported major.minor version 51.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
    at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
Process ended with code: 1

Link to post
Share on other sites
  • 3 weeks later...

Hello, I just wanted to join on the server, I downloaded the launcher above and started downloading the FTB:Infinity Evolved modpack but for some reason, the game won't launch properly. I uploaded the error message: Pastebin

I really hope someone on here might be able to help me out on this one!

 

Edit: Yes, I already tried reinstalling Java Runtime as suggested somewhere else on the internet, didn't work! :(

 

Edit 2: I played around with the maximum memory dedication thing, I put it lower to 3GB (3.072) and it seemed to work, dunno tho, but I stumbled across a new problem, the MaxPermSize can't be ignored, there was a warning, then the launch ended. I played around with PermGen too, but 4096MB doesn't work, as well as 1MB (1MB got changed to 64MB automatically). Pastebin

 

Edit 3 (final): By some miracle, I found a means to download the 64bit version of java after I got a pop-up telling me that I'm using a 32bit java version. Now it works, yay! :D

Link to post
Share on other sites
  • 4 weeks later...
  • 1 month later...

Someone please help! Even though I tried launching the Mac version and both universal versions of the Launcher none of them worked. They all came up with the same error message. I even updated my Java to see if that helped but it had no effect on the error messages. Does anyone know how to get the launcher to work on a Mac running MacOS 10.13.6 (High Sierra)?

Here's a pic of the error message I keep getting.

unknown.png?width=400&height=248

Link to post
Share on other sites
  • 4 weeks later...

The launcher is amazing for the most part, but there are a few things to improve here and there. First, some modpacks names are so long that I cant see them properly, fix this please. Also, the ram changing part is finiky and I would like it if there was a dropdown with 1234567ram and so on. Lastly, the interface and server selecthing/options menu needs more polish like the official launcher. But other then that great job!

Link to post
Share on other sites
  • 1 month later...

Yes I am getting the same thing Bross. I used to play on these servers and cannot play anymore because I cannot find out how to get this to work =(. I have tried uninstalling, reinstalling, making sure I have java 8(A link to java would be nice if for some weird reason I am not downloading the right one). Nothing works. Im in no mans land. 

Link to post
Share on other sites
  • 2 weeks later...
On 6/27/2018 at 11:28 PM, Yusixs said:

CraftersLand Launcher v1.1.3!

(Me, Henk and Brunyman were discussing ideas to be brought into CraftersLand back in May)

  Reveal hidden contents

Brunyman: We should get our launcher for CL back, we had one years ago which contained our first modded servers
Henk: Sounds good, it'll help us develop our custom modpacks easily and share with everyone with the addition of client side patches and a news section to increase everyone's experience on the server.
Yusixs: I like the idea of a launcher honestly, I can put some real effort into it after the exams

There was a lot more than that but this is basically the summary ?

 

And so it began, I embarked on the task to get it done after my exams (well, a tad bit after but oh well) and it went great! Albeit, it took me a couple of days to learn the ins and outs of this but it should contain almost everything you need for your experience on the server with the addition of optional custom Optifine and A LOT of other fancy features which i'm sure you all will enjoy. Best thing about this is that even cracked players can use this launcher! 

The modpacks available in this launcher are all of the ones we are currently hosting right now and will be updated whenever an official FTB update is released. Don't worry, you won't have to do anything to update the modpacks, the launcher does it by itself! This launcher is also capable of smart-updates, meaning that you don't have to re-download the entire modpack whenever a new update comes out. 

For all of you who play on our Network server out there, you are not left out either. I added in 2 "Forge Vanilla" modpacks which are MC Vanilla version 1.8.9 and 1.12.2. These vanilla minecraft instances have a lot of optional mods which you can choose and the server IP's are already included in them so you can launch these and join the server without any fuss.


Screenshots
 

unknown.png

unknown.png 

 unknown.png

unknown.png
 

Features

Support for both Cracked and Premium accounts! For cracked players, enter your name and click "Play Offline". For premium players, enter your ID and Password and click "Login..."
Custom Recipes on our Revelations, Infinity and Skyfactory 2.5 have been added client-side, so you all can view these recipes in NEI aswell.
TTKami config tweaked for Direwolf20 1.7.10 (Allows you to unlock TTKami Research on our server)
Automatic Console Window opens in the background to record errors for quick copy-pasting
Each Modpack already has it's own respective CraftersLand IP already added into it
Forge Vanilla installation with a handful of useful quality of life mods
Fix Direwolf20 industrial foregoing client-side crash with a patch
Shaders included in Forge Vanilla 1.12.2 (Disabled by default)
Schematica mod added as optional for every modpack
Optifine mod added as optional for every modpack
ReAuth mod added in almost every modpack
Smart-Updates capability
Discord RPC added for every modpack running in MC version 1.12
Vanilla Fix added as optional for every modpack running in MC Version 1.12

This launcher is a fork of the populat SKCraft Launcher, source code here:

GitHub_Logo.png



Download Below

Note:  There are 2 types of launchers, normal and portable. Normal one will download and install the modpacks in your My Documents folder (C drive). Portable one will download and install the modpacks wherever your launcher is (do not delete portable.txt else it wont work!).
Note: For Mac and Linux, use Universal Normal or Universal Portable.
Note: Java 9 and Java 10 will NOT work for this launcher, please use Java 8!
Note: If you are using 32-bit Java then the maximum memory you can allocate in options is around 2.5GB, any higher and it wont run

The following texts are click-able

Windows exe | Mac OS | Universal jar | Universal Portable jar

can someone please help me with what that means?

Messages and Errors 14_08_2020 02_35_17.png

Link to post
Share on other sites
  • 4 weeks later...
  • brunyman changed the title to CraftersLand Launcher Released! [v1.1.5 Fine-Tune your experience to the max!
  • 2 weeks later...
  • brunyman changed the title to CraftersLand Launcher Released! [v1.1.6 Fine-Tune your experience to the max!

Hey there, I don't see any options in the launcher to change the destination folder for installing the mod packs. Mine keeps defaulting to the Documents folder. I've moved all the files a few times but it's still installing there when I launch it...

Link to post
Share on other sites
  • 2 weeks later...

Invalid maximum heap size: -Xmx4096M
The specified size exceeds the maximum representable size.
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

 

Anyone could help me with this error? 

My PC is more than capable of running the game, so I guess it´s a problem with Java?

Link to post
Share on other sites
51 minutes ago, Magvin said:

Invalid maximum heap size: -Xmx4096M
The specified size exceeds the maximum representable size.
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

 

Anyone could help me with this error? 

My PC is more than capable of running the game, so I guess it´s a problem with Java?

had the same problem what i did is up the size in the setting for java so if i had 4096 i push it to 5125  or bigger and it work after that

 

Link to post
Share on other sites
  • brunyman changed the title to CraftersLand Launcher Released! [v1.1.7 Fine-Tune your experience to the max!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Guidelines.