Jump to content

[Henkekalmar] Worldedit bug, rollbacks?


Recommended Posts

Hello @brunyman.

I'm having issues with worldedit, I was going to regen a couple of chunks - a random worldhole and a town that was removed. But it doesn't seem to work... I mean I can regen it but it rolls it back after a single world save. Am I exceeding some cap or something that forces a rollback or my worldediting? - If so,.. can I get the cap raised?

I've tried to regen these chunks four times now.

Edit: sort of worked now...? No clue, this is weird.

Edit2: No, this time it broke again. Although the old chunks I regened that first didn't rollback now didn't either

Link to comment
Share on other sites

Having experienced it as well, I can confirm that this is becoming a bit of an issue. Still don't know why.

Maybe it's lag, or maybe it's Maybelline. It's not natural normal, I know that.

Link to comment
Share on other sites

Any fix possible for this...? It's very tedious. Does all versions have this bug or is it the fact that it's modded? 

Perhaps can replace all in a chunk to vanilla blocks then regen if that's the case?

Link to comment
Share on other sites

Okay, I've done some further testing to help tackle this problem, and I think I've reached a better understanding of it. 
All rollbacks happen after a server-save. Or a restart

If I regen a chunk and move away from it it will 100% of the time rollback.

If I regen a chunk and stay close it will 100% not rollback.

If I make manual changes to a chunk, then regening it it will still rollback. Even the manual changes.

If I make changes after the regening it will still rollback.

If I make changes before and after a regen it will still rollback.

Tried removing all modded blocks from a chunk (setting the entire chunk to air) still rollbacks to the state of which I worldedited it to.


So to my understanding, because a player is not closeby and loading the chunk when a server save comes around the server doesn't detect a change on the chunk and reverts it to the previous savefile. Whilst normal worldediting other than regen does trigger something and even when moved far away - to not load the chunks - it will still save the worldediting that was made. Is it possible to add //regen as a sort of "trigger", I'm not sure how the program works I can only assume. Or can you possible force-save the single chunk that was //regen'ed after a regen? Or with some method adding a temporary chunk-loading on that chunk for say 15 minutes just for a save to roll by.

Why is this not an issue on any other server? very strange.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

By using this site you agree to the following Terms of Use, Guidelines and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.